Having ad blocker problem

I have removed the Ad Blockers on both of my computers but I still get the annoying pop-up asking me to delete or disarm the Ad Blocker, What is going on???

Sorry to hear you are having a problem. I assume you mean the ad blockers on the different content sites we have. Did you switch off the ad blocker for that site or actually uninstall your ad blocker? It’s possible that it’s still cached on the page so doing a force refresh might fix the issue. But I have never run across that problem before personally. Normally if you do something like this…

It’s good to go.

Also if you get a message at the top of the screen for a short time like this:

Please disable your adblock and script blockers to view this page

This has nothing to do with you actually using an ad blocker, it’s pre-loaded so that if the page doesn’t load necessary elements due to an adblocker they will know why.

The graphic that you should be seeing if running an adblocker looks like this:

I am having ads pop up to, very very annoying!!

There are no ‘pop’ up ads or screens on our sites. Just regular old ads.

Sorry I meant popping up through the blogs like being half way reading a page update & am ad will appear.


I keep getting that annoying blockadblock message. My adblock is already paused on armorama site. Why do I keep getting that annoying message???

Which brand ad blocker are you using?

AdBlock. Got it from the web. Not sure if there is a brand.

So not “Adblock Plus”? Which is what I use and it was free. If it’s an older version you might want to consider updating it.

I use AdBlock Plus and have the same issue. The site is almost unusable, as the popup appears every 30s. And the ad bloker is configured to exclude the whole Armorama site.

I know the site had ads to generate some revenue and to advertise vendors to forum members, but I am never turning my blocker off. I don’t turn it off for any other sites; I got it for a reason: I don’t like advertising. If it means I can’t see an article, oh well. Usually the articles that get blocked turn out not to be so interesting anyway.

I have Ad Block Plus and have the content sites whitelisted and no ad block page/overlay comes up for me. I would try clearing your browser cache or updating your Ad Block Plus as clearly that’s not how it should work. What version are you using? Mine is:

That’s nice for you. However no advertising means no sites. I guess you are lucky for now that I haven’t found a way to add Adblocker to the forums. :smiley:

Oh and I have been on so many sites lately that have this feature that I did want to read their content my (partial) whitelist is this long. So yeah… we aren’t going to see eye-to-eye on this one. For you it’s still 1995 and the Internet is free of ads. Some of us have to live in 2021. :confused:

I have the same, AdBlock Plus 3.10.2. Armorama shows as whitelisted, but the popup continues to pop every 30s. I cleared the cache, and tried other browers with the same result.

Which browser are you using and on what OS? Also if you can send me a screen shot that includes the URL string that would be helpful. Thanks and sorry you are running into this issue.

I am using the latest 64bit Firefox with Windows 10 Enterprise.

I installed AdBlock Plus on my Firefox and (of course) it works just fine. Clearly there must be something different in your configuration of Firefox or some other security application may be causing the JavaScript that runs both applications to freak out. It’s almost like the page is full on cached and won’t reset. You have tried deleting your history/cached files right?

Yes, I cleared my cache. I am on the latest Firefox, and I only have AdBlock Plus, Google Translator for Firefox and a Downloader plugin. Well, I guess it is what it is…

On the other hand, I never encountered this problem elsewhere.

Well… what can I say? I am sorry you are running into this sort of problem. If it was me and I wanted to access the info I would either temporarily disable my ad blocker from running at all, or I would probably just use one of the other 2 clients I have installed on this machine. But ‘workarounds’ are part of my job, so I am use to that stuff.

I tried Chrome with no extensions whatsoever. Same issue.